PyroCMS

a HTTP web-server of some description

Apache 2.x, Abyss Web Server, Uniform Server, Zend Community Server, etc. So far PyroCMS only seems to struggle with IIS.

MySQL 5.x or higher

There are plans for other database systems, but for now the newer MySQL version the better.

PHP 5.2.x or higher

PHP 5.2 and PHP 5.3 are both fully supported.

GD 2

This library needs to be installed on your server with PHP compiled to include it. Usually your package manager will take care of this for you, if not you can get it here (the Libgd wiki is currently unavailable.)

cURL

libcurl 7.10.5 or greater need's to be installed on your server with PHP compiled to include it. Usually your package manager will take care of this for you, if not see instructions here.

Bundled Requirements

PyroCMS uses these third-party packages to run, but includes them in each release so you do not need to install them yourself: